Aesthetix DAC problems

Think there’s a couple of Aesthetix owners here, know @htm_1968 has a Pandora.

My Romulus DAC is having tantrums at the moment and is intermittently going silent, only way to fix is to unplug and re-plug the USB cable.

Currently using an Innuos Zen via USB to the Romulus and have also tried using the laptop via USB and Pi running volumio and both these go silent as well so to me it looks like a problem with the USB interface in the DAC.

Before I contact the dealer and have to go through the bollock ache of shipping it back has anyone else had similar problems?

Perfect timing before the holidays!

Is the co-axial input working ok?

Yep that seems to be fine.

Hahaha Just checked the invoice and typically it was 12 months old yesterday :roll_eyes:

Nick @Myrman has one, I think.
Many good dealers are not going to worry about a few days/weeks on the warranty.
Give them a ring. It may be a problem they know about, and there might be a quick/easy fix.
Is the fimware/software up to date?

They don’t provide any firmware updates for it on their website.

Kind of hoping the dealer will just send a new USB module or I can send mine back to them. There’s no way I’m shipping a DAC over the xmas period.

I remember having issues with an older Innuos, and it was the Innuos that was the problem. I think they had me use a USB filter, of a certain type, to fix it. No issues with the newer one.

It’s not the innuos, happening with other sources as well.

I’ve never really used the USB input on my Pandora much. I go from the Lumin into the DAC via coax. I did have issues where the DAC needed to be restarted after it shat it’s pants but that seemed to go away with a change of valves as I’ve not had the problem for years (inevitably my DAC will now break).


The USB is its major strength to me, I haven’t heard any USB DAC sound as good as the romulus. They have a very good clock and power supply for USB so it’s my first choice (that and the Zen has only got a USB interface)

I hope it’s not the valves as I’ve put fucking expensive foo’y ones in there (although I do leave it switched on 24/7 so they could be knackered by now at around 8000 hrs)

I turn mine off at the end of the day. I never did the 24/7 thing even in the height of Naim ownership.

1 Like

I don’t use the USB in my Romulus. Not sure what to suggest apart from going back to your dealer :thinking:
Just don’t leave it till after Christmas before you contact them even if you don’t ship it anywhere till the new year.

If you don’t get any help from the dealer, which I doubt, this lot are the UK service agent.

It’s only because it’s a faff to switch on.

I expect the dealer will be ok, it’s Cool Gales and they were really helpful when I bought it but the website says they closed for covid.

Hopefully they’re monitoring email.

Have you got a USB filter/purifier?
Try one of those.
If you need one to try, I can send you one.

No and it shouldn’t need one as the USB module is pretty much the dogs danglies.

I’ve taken the USB module out and given all the connectors a clean with deoxit after finding this thread and it’s been ok for an hour.

1 Like

Try a different cable. USB can sometimes be funky about them.


When I was talking to Innuos, sometimes it isn’t about the quality of the USB module/DAC, as the different way they implement things, hence some things don’t like connecting to other things.
They even had USB hubs that didn’t work, and recommended particular ones.

Have already tried a few, latest is a posh Supra one I got in Oct.