Fixing an Odroid

The odroid I was using as a squeezebox server stopped working, a while ago now. It’s been so long since I’ve had to touch it that I’ve pretty much forgotten how to do anything with it…

How the hell do i go about diagnosing and hopefully fixing it??

I remember that I saved images of the the sd card on the laptoo

Damnit. Laptop with the emmc image won’t start

Anyone advise how to get past this???

It may have sorted itself out…

Hmmm ok …so I’ve not had to touch the odroid in over 2 years so prob not surprising that I have no idea what to do

I formatted the emmc card using SDformatterv4 via a usb sd emmc adapter thingy. Did complete format /erase. Using usb image tool to restore most recent image. For some reason it said the image was too large. I may have done something wrong… I selected “truncate oversize images…” and it started restoring…

I realised that I can’t remember which usb slot the external HD was plugged into… Can’t remember if that matters for Linux mounting?

It probably doesn’t matter which USB slot the drive is plugged into.

I’d be tempted to download the latest version of the software and start again

Are you using one of the packages? Squeezeplug or max2play or something

Tried the back up image then tried max2play. No boot with either. The emmc might be gubbed. Need to dig out an SD to try.

Did you follow the instructions correctly? You probably need to tick something to make it bootable.

Unrelated: my autocarrot chose “fuck” for tick. Hmm.

1 Like