Laptop help

Symptoms: flickering screen, might go off completely for a few seconds, or flicker about 5 times a second. Totally unusable. Whether plugged in or not.

Possibly unrelated: doesn’t appear to be charging despite being plugged in.

It’s an Asus, just over 2 years old, was cheap. Always been a bit shit, but it did used to work.

Any ideas what the problem could be? I’m thinking something to do with the internal power supply, which is probably not fixable. I did think loose connection, but it didn’t change if I gently manipulate it…

The connector between the panel and the motherboard might need re-seating, or the lamp is dying. If it’s an LED backlight, they don’t require the high voltage CCFL based ones did, so that rules out a faulty inverter.

It wouldn’t be that difficult to dismantle it and take a look, you just have to go slowly and examine the connections to determine whether the locks need to be lifted/tilted etc to prevent damage.

I had a couple of BenQ monitors which I tossed after a year because the LED arrays would randomly not switch on, meaning the middle or one of the outer edges would be too dim to read. I didn’t bother trying to fix them as they were cheap, I just parted them out to the guys at work who teach electronics.

The battery not charging is likely just a dead battery - not all batteries last as long as they are meant to. The charge circuit could be broken, but meh. If the power supply as a whole was broken I’d expect you’d see far more problems related to performance and reliability (in terms of crashing applications, etc.)

Back up any data which is important before you go inside it with any tools.


Have you tried kicking it?

This is more useful than what I vaguely suggested.

I might take it apart, yeah. I keep no data on it, that’s all on a backed up server, so there’s nothing to lose. I’ll have a look later, before the inevitable defenestration and ebay. There are some decent Lenovo machines for £200.

If you’re not worried about it being brand new, look at the Thinkpads which use the 3rd generation Intel core i CPUs. They’re cheap now and are better made than the brand new £200.00 setups. Few years old but as long as you have an SSD in there and 8GB of RAM, you won’t run into many issues in use.* - this wouldn’t be dreadful.

*Unless something breaks, obviously.

it is worth taking apart to check the connector. If that fails to remedy, I’d say the screen was on its way out.

Have you tried switching it off and then back on again?


Yeah I was looking used, loads of ex business machines out there. Just need to decide on screen size really, I might go for a 1600x900 one.

1 Like

Oops this seemed too good to miss…

1 Like

We have some hp all-in-ones at work - some are Pentium quad cores, the last lot we bought are i5 quad core - not sure which actual SKU the CPUs are but they work well enough. The i5s are overkill, but we specced them purely because one of the IT team in my office wanted an i5 for his desk PC. Obviously, he was told no, etc.

I have an hp elitebook with a 2nd generation i7 in it, big, heavy, survived a few knocks and it’s survived being torn apart a few times to upgrade memory. I can’t fault it really, but I’d prefer a Thinkpad if I were spending my own money.

Let us know how you get on.

…tempted to get one of those myself.

Given my specific needs - it doesn’t need to move, but I don’t have room for something too big - I started to look for small PCs and separate monitors, thinking I could mount the PC under the table. But for £220, this all in one looks amazing - huge high resolution touch screen, performance is fine (it’s just used for music and a bit of browsing), and I’m looking forward to listening to music with a touch screen within reach for selecting tunes.

I’ll add the Asus to the pile of shitty half working laptops I have :rofl:

1 Like

me too - not sure where I’d put it though…

Well that’s the laptop fixed, a day before its replacement arrives :rofl:


Start your own cryptocurrency farm.

Not sure that the old Celeron will prove that lucrative

what was wrong with it in the end?

Just a loose connection. Poked and prodded inside and it works.

I did manage to pull out the connector to the track pad, which I can’t get back in, but as I hate track pads with a vengeance that’s no real loss.

You could sell that service as a mod on ebay and make some money. Everyone I support at work hates their trackpad.