Networking pain in the arse

Something has changed in my setup here over the last few weeks. I can control my Innuos via a browser using the IP address. However, the Innous (and a new NUC) do no show up in the Network window of File Explorer. Also the shortcut to the HDD of the Innuos which I set up a while back does not work. The troubleshooter tells me:

Your computer appears to be correctly configured but the device or resource (IP address of Innuos) is not responding.

There were two separate changes:
(i) The Innuos disappeared from the Network according to Windows following an update. This was when I set up the shortcut.
(ii) The shortcut stopped working following a change of Modem/Router on Monday.

I’m running Windows on a HP notebook.

Have you tried turning it off and turning it back on again? Hope this helps :clown_face:


Were inuus and nuc using dynamic or static IP before you changed the router?

If dynamic then they have almost certainly been given a different IP address by the new router, if static u need to check that new router is using same ip range as old one, otherwise they may be on a different network

The Innuos IP is unchanged in all of this…

Yes. Several times.

This could be classic Windows Update fuckery. I wonder if it has reset some adaptor settings of your desktop machine.

Have a look in sharing options to see if your original home network visibility settings have been changed.

Does your shortcut point to the ip address or a dns name?
If name, they you may need to add it tot he routing table in new router so it knows what ip the name refers to, unless you have another DNA server elsewhere

The shortcut points to an IP address. I can use a browser to connect to the device via this address. I cannot map the feckin’ thing as a network drive though. It is a NAS so this is a bit of an issue.

Errrm, I would need to know those settings wouldn’t I?


Once you go in the descriptions are fairly self-explanatory. You want stuff to be visible.

1 Like

If you had uPnP enabled on your network before, a setting may have changed there that could also be affecting network visibility.

that was my first question.

I have to say, my cross mounts to my NAS are exceptionally reliable. But since moved all my music from my NAS to the Aries Mini, the AM keeps dropping off the network shares.

in the router or as set in the Innuos.

1 Like

Haha windows notworking. Always has been hit and miss (mainly miss).


It’s the endless computer/networking fuckwittery that makes digital such a pain. No wonder vinyl is resurgent.

1 Like

No idea where it was set, but it hasn’t changed.

Ironic post. Love it.


I can remember the pain of making this work in the charity I worked for that had very little money for IT.

1 Like

So, I got everything up and running again (sort of) but then noticed that I had an email from @maverick today. Effectively, Paul said:

it is an issue with SMBv1 if you are using Windows 10?
Basically Windows 10 Home and Windows 10 Professional still contain the SMBv1 client by default

So for Windows 10 - if the SMBv1 client or server is not used for 15 days in total (excluding any time during which the computer is off), they each automatically uninstall themselves. thanks M$

Automatic removal of SMBv1 after 15 days is a one-time operation. If an administrator re-installs SMBv1, no further attempts will be made to uninstall it (this is good news)

so check this:
Control Panel>programs and features>Turn Windows features on or off find SMB 1.0/CIFS File Sharing Support and check all the boxes - note it has three sub-items.


Soooo, following Paul’s advice I reinstalled SMBv1 and everything works again. What a fucking stupid and useless update!!

Many thanks to Paul, and perhaps those of us using Windows 10 might like to reinstall SMBv1 to get stuff going again.

1 Like