New router req'd

Apparently my (8yo) TP-Link router isn’t compatible with my new Sky Q box (or at least the engineer thinks it isn’t)

So I’m relying on his best guess being correct and looking for a new one.

It needs to have 4 ports and able to be linked to my recently installed TP Link access point (hard wired) in the music room. Other than that it only has to deliver wifi in the house for MacBook and iPhone,

This is what I’m considering

I don’t know a lot about this sort of shit so any advice/comments appreciated.

How is it not compatible? or what is happening to think it’s an issue.

The SkyQ boxes do some weird things so it may just be a router setting needs changing.

PS what is the TP-Link router model?

He tried installing an update to the router to see if that helped but it wouldn’t accept the update.

It’s an Archer C2 ?

helped what, without knowing what the issue is can’t give any advice.

how are you connecting the SkyQ to the router, ethernet (hardwired) or WiFi?

Connection by ethernet.

The SkyQ box works fine until you connect it to the router and then I just get a blank screen with a banner at the top saying channel not available - technical fault

Nothing works after that - no free to air or premium channels are available and you have to disconnect the router and do a factory reset on the Q box to get thing working again.

Have you tried connecting the SkyQ box to wifi instead.

Trying that now.

when you change the network from cabled to wifi it does a network reset as well so that may help.

It is saying that it’s connected to wifi and all features seemed to work at first.

However, the moment I tried to record a programme (just as an experiment) it went back to “technical fault” and everything stops working again.

Just done another factory reset and it’s working again but NOT connected to internet. No matter whether it’s wifi or ethernet it just fucks up and needs to be reset.


sounds like a SkyQ box problem

what does it say for software and hardware version in settings > system info

It’s a brand new box installed today after experiencing the exact same problems with the new one installed a fortnight ago.

Sky have confirmed that the software and hardware versions are the latest ones.

I had this problem we we got it installed, had to enable ICMP packets through the gateway

This, you need to understand the problem really. Incompatibility really shouldn’t be a thing in a simple home network as long as each device is fairly standard.

You could buy the new router and see if it fixes it, I guess, as it’ll probably have faster wi-fi anyway, so that’s a useful benefit.

The SkyQ box has a builtin switch so can cause issues with switches/routers with spanning tree as it presents two MAC addresses but I’ve never heard of a box pretty much crashing when on the network

I have, cos I watched it happen here for an hour or so until I managed to poke open just the right set of magic holes through the firewall to make it happy. Since then it has been fine.

otoh, I dont use a domestic firewall, they generally let everything out so not sure why @pmac is seeing this problem

1 Like

That ICMP thing does ring a bell now as I’m using a Cisco FTD firewall on mine and think I had to do the same but like you say ‘domestic’ router firewalls normally let anything out

You could try this but the engineer may be right and the TP-Link is being a bit shit

My solution:

  • Trying a few things, this finally worked for me:
  • Turn off “Smart Connect” mode on the AX1800 router (I used the Tether App for this)

If that doesn’t help I was using an Asus RT-AX86U with my Sky Q box ok.

If you want I can post it to you to try and check it works before buying one?

1 Like

It does seem like a Q box/router issue

It works fine with my Sky HD box but to change that back I also have to change the LNB on the dish :roll_eyes:

I’ll see if I can borrow a different router locally to try first but thanks for the offer.