Upgrading LMS

Continuing the discussion from Qobuz:

Can you technobeasts help me out with this. I run version 7.9.2 of LMS in my QNAP’s Container Station app on Docker. The Docker itself is running some version of Ubuntu.

I’d like to upgrade to v8 to try the streaming integration.

  1. Is there a recognised upgrade path from 7.9.2?
  2. Do you know what the terminal commands are to upgrade it?

Upgrading to v8 is just an install over v7.9.x

That said, some third party plugins have a max version of 7.9, so on first run they will flag as incompatible, and on second run they will be deleted. You may wish to (1) update plugins, and then (2) amend the install.xml file to change the maxversion from 7.9 to *

I think you need this file:

From here:

A. Cancel any ongoing media scans (LMS initiates a scan automatically when launched)
B. Click on the upgrade link which will take you to the LMS updates page. Here you should click on the “Click here for further information” which moves you onward to the information page which will give you a step by step guide on what to do. The important part there is the command including the correct path in order to do the upgrade. Make a copy of that command line for later use (store it in Notepad or somewhere else).
This command typically looks something like this:
sudo dpkg -i /srv/squeezebox/cache/updates/logitechmediaserver_7.9.0~1466175427_amd64.deb
Now, what you do not see, is that LMS downloads the deb package in the background, and because these packages can be rather large, you must not interrupt, close or stop LMS while it is still downloading. There is, regretfully, no easy way to tell when it is finished downloading except peeking into the container and looking at the content in the above given path. But if you know your internet connection speed fairly well, you have a rough idea how much time it takes to download approximately 50-100Mb (?). To be on the safe side, take a half hour nap before moving on. Your upgrade will fail if the download is not complete.

Then you need to SSH inside the container to get terminal access. Here is how:

  1. Open the container status page for LMS in Container Station and copy the Container ID.
  2. Use Putty (or whatever terminal emulator you like) and log into your NAS
  3. Type: “docker exec -i -t bash” replacing with the ID you found.
  4. Once inside the container, you should see something like: root@<name_of_your_NAS>:/#
  5. Then type the command that you found in step B above: sudo dpkg -i /srv/squeezebox/cache/updates/logitechmediaserver_7.9.0~1466175427_amd64.deb
    (replace the path and the package name with what you found)
  6. Be patient. It takes a while to unpack, install and setup LMS. You will get the prompt back in the end.
  7. log out of the container by typing exit

Note that if LMS doesn’t see the v8 as an upgrade, you’ll need to download it yourself:
sudo wget http://downloads.slimdevices.com/nightly/8.0/lms/a646e60d7359876872a061aa3a25f2ec82474865/logitechmediaserver_8.0.0~1583188601_arm.deb

sudo dpkg -i logitechmediaserver_8.0.0~1583188601_arm.deb
Inside the container malarkey in the above

Edit: my steps would basically replace step 5 in that list


Thanks mate. It was getting the download of v8 that I was struggling with. It looks like

this is what I need.

Cool, have fun!

Mine took a while to get going properly, in that it didn’t show the Qobuz stuff in New Music for a while, but now it works.

Well, I have managed to break it.


Excellent! A shit three hours is your future!

1 Like

I admire you admitting this in a public space.

Question for one/both/randomly fired into the ether. Can the Innuos servers be updated in this way?

You could listen to some records while you try and unFUBAR it.

1 Like

I am pretty sure you can’t. Innuos control what and when the updating occurs.
I have a Zenith.

Is it just a linux box with a front end? If so then probably, but I’d check with them first. It strikes me that they are selling a managed, packaged solution - if you wanted to load up beta software yourself then you’d be using a different solution really.

That sounds suspiciously similar to the sort of nonsense I do at work :angry:

Actually it looks locked down enough that there is no terminal in their web UI. You need to be able to open a terminal page, probably via Putty, and that would need a username and password.

You could try getting Putty, accessing the Innuos and trying the default vortexbox password (user root, pw vortexbox). If you can log in then you can update it.

At your own risk :slight_smile:

You’re in charge of support when someone bricks their Zen then :kissing_heart:

I neither own an Innuos nor have the slightest desire to try anything that involves typing “docker exec -i -t bash” but it was more thinking (in my shamelessly commercial way) that if Innuos does roll this out to their boxes, it’s going to extend the advantage they already enjoy over rivals.

1 Like

Hmm, the advantage of packaging open source software into a digital audio streamer for ££££ when a Raspberry Pi can do exactly the same thing for a hundredth the price!

exactly why I gave up with LMS on my NAS - it was flaky as hell and as unreliable as a Porsche

It’s not in the slightest bit flaky. I want to do an upgrade in a Docker - which I freely admit I don’t properly understand. Any flakiness is down to the operator, i.e. me.

That’s why you shouldn’t run it on a NAS, they tend to be rather underpowered unless you get a decent one, and you don’t have complete control over how stuff works on them. My LMS happily has uptime measured in weeks/months on a Pi 4, despite it running a lot of other stuff.

I reiterate. What works for a subset of people is of absolutely no appeal to many others. I frequently have to deal with Chord Electronics customers hours deep in Foobar plugins who, if they made any calculation of their hourly rate, should have just paid for software that came pre-configured. I don’t doubt you obtain reasonable results on a limited spend. Assuming that everyone would achieve the same results is- bluntly- stupid.

1 Like

Thinking about it, it seems quite a good idea to run these things in Docker, you can have different servers (web servers, LMS, photo servers, Nextcloud, torrents etc) each with their own instance, and if you balls one up you can just kill it without breaking everything else, and reinstall the previous working iteration.

I’m planning on adding Nextcloud and an email server to my Pi, and I’m a bit concerned that if it goes down then I’ll lose my whole life. I might think about virtualising it a bit more…